|
Join the conversation
Showing results for 
Search instead for 
Do you mean 
Join the conversation
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted

Internet has been slow for the past 2 weeks

Member
Posts: 1
Registered: ‎01-01-2018

Dear Digi,

 

I've been enjoying very good speed since the day I subscribed to your Broadband services in June 2017. The speed was at least at 30Mbps til up to 60Mbps (tested with Ookla). However, since middle of December 2017 till now, the download speed has been very slow, topping to the most 1.5 Mbps and most of the time below 1Mbps. I thought I have problem with my portable modem, but I also did subscribe to Digi postpaid services for my phone and it is also dead slow. I thought it's my problem alone, but when my friend came over for a visit, he used Digi too, and he also complained to me for such slow download speed. Strangely speaking, upload speed is still good, ranging from 20Mbps - 50Mbps.  FOr your information, Digi signal here is excellent, always full bar and 4G-LTE.  I tried speed testing roughly 1km outside from my area and it is excellent, speed test showed download speed of 70Mbps. My house located not far from the telco tower which I believed contributed to the strong signal.

 

I tried to post to your Twitter, FB - no reply. Complained through myDigi app too, but no response til now. Try calling your customer service it's always busy. I don't know what else can I do now. If this continues, I'm considering to opt out from Digi because to me it's such a waste for me to pay close to RM200 a month for both broadband and postpaid for nothing. 

 

For your information, this photo shows the speed at my area here (Taman Samariang Aman 2, Phase 5 Plot 4 - HSL).

 

Please, if no response within these 15 days (till my last bill cycle), I think I'm done. Will consider to opt out. Thanks.

 

Speedtest by Ookla   The Global Broadband Speed Test.png

Top Kudoed Authors

Meet our Support team and SuperUsers